summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:24:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:45 +0200
commit04bab95e81de8bf654df567679dd3e704170277b (patch)
tree80258769ed1f76e703dba77d7abfb96d31150a5b
parentdfc6b32e7668b4aa6eeaef457b58c25d0ea0537c (diff)
downloadguix-04bab95e81de8bf654df567679dd3e704170277b.tar.gz
gnu: Add texlive-hepthesis.
* gnu/packages/tex.scm (texlive-hepthesis): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7301bfe653..06e46d7bb4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4022,6 +4022,36 @@ disappear if these macros are used.
 @end enumerate")
     (license license:lppl)))
 
+(define-public texlive-hepthesis
+  (package
+    (name "texlive-hepthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/hepthesis/"
+                   "tex/latex/hepthesis/")
+             (base32
+              "10yrdsrvnb259fi2qyjldwc6h55s5z8vadr5pf6sbaihyqnv9igg")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hepthesis")
+    (synopsis "Class for academic reports, especially PhD theses")
+    (description
+     "@code{hepthesis} is a LaTeX class for typesetting large academic
+reports, in particular PhD theses.  In particular, @code{hepthesis} offers:
+
+@itemize
+@item attractive semantic environments for various rubric sections;
+@item extensive options for draft production, screen viewing and binding-ready
+output;
+@item helpful extensions of existing environments, including equation and
+tabular;
+@item support for quotations at the start of the thesis and each chapter.
+@end itemize
+
+The class is based on @code{scrbook}, from the KOMA-Script bundle.")
+    (license license:lppl)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")