summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 23:39:13 +0200
committerMarius Bakke <marius@gnu.org>2022-08-13 19:24:34 +0200
commit06db41651c521dd9feb58953e98d690ae17298bf (patch)
treeed06df9a2f2dc7cecae8fedea836e3a0a8b96883
parentc87700e691b80b2a6c6b231e426dec0d43face50 (diff)
downloadguix-06db41651c521dd9feb58953e98d690ae17298bf.tar.gz
gnu: python-m2r: Adjust for Python 3.10.
* gnu/packages/python-xyz.scm (python-m2r)[source](modules, snippet): New
fields.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 42e2b00d48..22f1c4043a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19093,7 +19093,15 @@ from the header, as well as section details and data available.")
               (uri (pypi-uri "m2r" version))
               (sha256
                (base32
-                "16gdm8i06jjmlpvckpfmlkr4693dh0vs192vgsqn84fsdkbbm45z"))))
+                "16gdm8i06jjmlpvckpfmlkr4693dh0vs192vgsqn84fsdkbbm45z"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Adjust test regex for Python 3.10 compatibility.
+               ;; Taken from upstream pull request:
+               ;; https://github.com/miyakogi/m2r/pull/62
+               '(substitute* "tests/test_cli.py"
+                  (("self.assertIn\\('optional arguments:', message\\)")
+                   "self.assertRegex(message, r'option(s|al arguments):')")))))
     (build-system python-build-system)
     (propagated-inputs
      (list python-docutils python-mistune))