summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-24 09:59:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-24 11:15:17 +0300
commit0792d9946602a54a5318f7818cfe3307e9ef333d (patch)
tree24183d459003cd7ed0cf1d726a67d610d5de3303
parenta338a553e3bed0d33b964b87f5acc153e2b424bf (diff)
downloadguix-0792d9946602a54a5318f7818cfe3307e9ef333d.tar.gz
gnu: htslib: Link against htscodecs.
* gnu/packages/bioinformatics.scm (htslib)[source]: Add snippet to
remove bundled htscodecs.
[arguments]: Add configure-flag to link against htscodecs.
[propagated-inputs]: Add htscodecs.
(htslib-1.14, htslib-1.12): Use bundled htscodecs.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 24 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2ea856d23f..1ed8b6c7a5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6721,7 +6721,11 @@ name/ID compression and quality score compression derived from fqzcomp.")
                     version "/htslib-" version ".tar.bz2"))
               (sha256
                (base32
-                "093r1n4s134k50m9a925yn95gyi90ps5dlgc6gq4qwvkzxx7qsv0"))))
+                "093r1n4s134k50m9a925yn95gyi90ps5dlgc6gq4qwvkzxx7qsv0"))
+              (snippet
+               #~(begin
+                   (use-modules (guix build utils))
+                   (delete-file-recursively "htscodecs")))))
     (build-system gnu-build-system)
     ;; Let htslib translate "gs://" and "s3://" to regular https links with
     ;; "--enable-gcs" and "--enable-s3". For these options to work, we also
@@ -6729,12 +6733,13 @@ name/ID compression and quality score compression derived from fqzcomp.")
     (arguments
      `(#:configure-flags '("--enable-gcs"
                            "--enable-libcurl"
-                           "--enable-s3")))
+                           "--enable-s3"
+                           "--with-external-htscodecs")))
     (inputs
      (list bzip2 curl openssl xz))
     ;; This is referred to in the pkg-config file as a required library.
     (propagated-inputs
-     (list zlib))
+     (list htscodecs zlib))
     (native-inputs
      (list perl))
     (home-page "https://www.htslib.org")
@@ -6757,7 +6762,14 @@ data.  It also provides the @command{bgzip}, @command{htsfile}, and
                     version "/htslib-" version ".tar.bz2"))
               (sha256
                (base32
-                "0pwk8yhhvb85mi1d2qhwsb4samc3rmbcrq7b1s0jz0glaa7in8pd"))))))
+                "0pwk8yhhvb85mi1d2qhwsb4samc3rmbcrq7b1s0jz0glaa7in8pd"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments htslib)
+       ((#:configure-flags cf #~'())
+        #~(delete "--with-external-htscodecs" #$cf))))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs htslib)
+                    (delete "htscodecs")))))
 
 (define-public htslib-1.12
   (package/inherit htslib
@@ -6769,7 +6781,14 @@ data.  It also provides the @command{bgzip}, @command{htsfile}, and
                     version "/htslib-" version ".tar.bz2"))
               (sha256
                (base32
-                "1jplnvizgr0fyyvvmkfmnsywrrpqhid3760vw15bllz98qdi9012"))))))
+                "1jplnvizgr0fyyvvmkfmnsywrrpqhid3760vw15bllz98qdi9012"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments htslib)
+       ((#:configure-flags cf #~'())
+        #~(delete "--with-external-htscodecs" #$cf))))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs htslib)
+                    (delete "htscodecs")))))
 
 (define-public htslib-1.10
   (package/inherit htslib