summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-01-20 22:29:55 +0100
committerAndreas Enge <andreas@enge.fr>2013-01-20 22:29:55 +0100
commit079fca3be86e38bcbefa67e6f07b7ff440726ceb (patch)
tree553807fc37e170af89039954d5e2785047665db9
parentf6ab05509c903cbd237179412b0923f14f44e333 (diff)
downloadguix-079fca3be86e38bcbefa67e6f07b7ff440726ceb.tar.gz
gnu: mit-krb5: Patch and enable tests.
* gnu/packages/mit-krb5.scm (mit-krb5): Enable patched tests.
-rw-r--r--gnu/packages/mit-krb5.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/mit-krb5.scm b/gnu/packages/mit-krb5.scm
index 4fbd301957..141957697c 100644
--- a/gnu/packages/mit-krb5.scm
+++ b/gnu/packages/mit-krb5.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,22 +43,35 @@
              ))
    (arguments
     (lambda (system)
-      `(#:tests? #f
-        #:phases
+      `(#:phases
         (alist-replace
          'unpack
          (lambda* (#:key source #:allow-other-keys)
-          (system* "echo" source)
           (let ((inner
                  (substring source
                             (string-index-right source #\k)
                             (string-index-right source #\-))))
-           (system* "echo" inner)
            (and (zero? (system* "tar" "xvf" source))
                 (zero? (system* "tar" "xvf" (string-append inner ".tar.gz")))
                 (chdir inner)
                 (chdir "src"))))
-          %standard-phases))))
+      (alist-replace
+       'check
+       (lambda* (#:key inputs #:allow-other-keys #:rest args)
+        (let ((perl (assoc-ref inputs "perl"))
+              (check (assoc-ref %standard-phases 'check)))
+          (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+                       (("/bin/cat") (string-append perl "/bin/perl")))
+          (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+                       (("D/bin/sh") (string-append "D" (which "bash"))))
+          (substitute* "plugins/kdb/db2/libdb2/test/run.test"
+                       (("bindir=/bin/.") (string-append "bindir=" perl "/bin")))
+           ;; use existing files and directories in test
+          (substitute* "tests/resolve/Makefile"
+                       (("-p telnet") "-p 23"))
+           ;; avoid service names since /etc/services is unavailable
+          (apply check args)))
+          %standard-phases)))))
    (synopsis "MIT Kerberos 5")
    (description
     "Massachusetts Institute of Technology implementation of Kerberos.