summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 11:08:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:30 +0200
commit08451b976fdc6a60166ac33ba2507f5b4d8e49ef (patch)
tree69f7d446abcd50c14f75fb7a4cbc25d880701d91
parentbde876b4817977aabcbf28402d8ba263a4a71821 (diff)
downloadguix-08451b976fdc6a60166ac33ba2507f5b4d8e49ef.tar.gz
gnu: rust-multipart: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-multipart-0.18, rust-multipart-0.17):
Move from here ...
* gnu/packages/crates-web.scm: ... to here.

Change-Id: Iae0f41f180afd94d261eb0a0c6c4a05b705017e3
-rw-r--r--gnu/packages/crates-io.scm76
-rw-r--r--gnu/packages/crates-web.scm76
2 files changed, 76 insertions, 76 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 791fa69bff..3162d2db7c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37158,82 +37158,6 @@ multiplication and division with overflow protection.")
     (description "This package provides a multimap implementation.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-multipart-0.18
-  (package
-    (name "rust-multipart")
-    (version "0.18.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "multipart" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "10libwfbazqcyxcpgpcdf1a66jnzghwlmxlxnffg4rrqhqrwdph0"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-buf-redux" ,rust-buf-redux-0.8)
-        ("rust-clippy" ,rust-clippy-0.0)
-        ("rust-httparse" ,rust-httparse-1)
-        ("rust-hyper" ,rust-hyper-0.10)
-        ("rust-iron" ,rust-iron-0.6)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-mime" ,rust-mime-0.3)
-        ("rust-mime-guess" ,rust-mime-guess-2)
-        ("rust-nickel" ,rust-nickel-0.11)
-        ("rust-quick-error" ,rust-quick-error-1)
-        ("rust-rand" ,rust-rand-0.8)
-        ("rust-rocket" ,rust-rocket-0.4)
-        ("rust-safemem" ,rust-safemem-0.3)
-        ("rust-tempfile" ,rust-tempfile-3)
-        ("rust-tiny-http" ,rust-tiny-http-0.6)
-        ("rust-twoway" ,rust-twoway-0.1))
-       #:cargo-development-inputs
-       (("rust-env-logger" ,rust-env-logger-0.5))))
-    (home-page "https://github.com/abonander/multipart")
-    (synopsis "Backend-agnostic extension for file uploads in HTTP libraries for Rust")
-    (description "This package provides a backend-agnostic extension for HTTP
-libraries that provides support for POST multipart/form-data requests on both
-client and server.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-multipart-0.17
-  (package
-    (inherit rust-multipart-0.18)
-    (name "rust-multipart")
-    (version "0.17.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "multipart" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1m3nrydgc56wjixsahipmvjgnxnw2cz7w8ryghsgahwjr3nswl6h"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-buf-redux" ,rust-buf-redux-0.8)
-        ("rust-clippy" ,rust-clippy-0.0)
-        ("rust-httparse" ,rust-httparse-1)
-        ("rust-hyper" ,rust-hyper-0.10)
-        ("rust-iron" ,rust-iron-0.6)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-mime" ,rust-mime-0.3)
-        ("rust-mime-guess" ,rust-mime-guess-2)
-        ("rust-nickel" ,rust-nickel-0.11)
-        ("rust-quick-error" ,rust-quick-error-1)
-        ("rust-rand" ,rust-rand-0.7)
-        ("rust-rocket" ,rust-rocket-0.4)
-        ("rust-safemem" ,rust-safemem-0.3)
-        ("rust-tempfile" ,rust-tempfile-3)
-        ("rust-tiny-http" ,rust-tiny-http-0.6)
-        ("rust-twoway" ,rust-twoway-0.1))
-       #:cargo-development-inputs
-        (("rust-env-logger" ,rust-env-logger-0.5))))))
-
 (define-public rust-multiversion-0.6
   (package
     (name "rust-multiversion")
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 158a76f7d7..94e7622da9 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2669,6 +2669,82 @@ uses libcurl as an HTTP engine inside, and provides an easy-to-use API on top
 that integrates with Rust idioms.")
     (license license:expat)))
 
+(define-public rust-multipart-0.18
+  (package
+    (name "rust-multipart")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "multipart" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "10libwfbazqcyxcpgpcdf1a66jnzghwlmxlxnffg4rrqhqrwdph0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-buf-redux" ,rust-buf-redux-0.8)
+        ("rust-clippy" ,rust-clippy-0.0)
+        ("rust-httparse" ,rust-httparse-1)
+        ("rust-hyper" ,rust-hyper-0.10)
+        ("rust-iron" ,rust-iron-0.6)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-mime" ,rust-mime-0.3)
+        ("rust-mime-guess" ,rust-mime-guess-2)
+        ("rust-nickel" ,rust-nickel-0.11)
+        ("rust-quick-error" ,rust-quick-error-1)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-rocket" ,rust-rocket-0.4)
+        ("rust-safemem" ,rust-safemem-0.3)
+        ("rust-tempfile" ,rust-tempfile-3)
+        ("rust-tiny-http" ,rust-tiny-http-0.6)
+        ("rust-twoway" ,rust-twoway-0.1))
+       #:cargo-development-inputs
+       (("rust-env-logger" ,rust-env-logger-0.5))))
+    (home-page "https://github.com/abonander/multipart")
+    (synopsis "Backend-agnostic extension for file uploads in HTTP libraries for Rust")
+    (description "This package provides a backend-agnostic extension for HTTP
+libraries that provides support for POST multipart/form-data requests on both
+client and server.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-multipart-0.17
+  (package
+    (inherit rust-multipart-0.18)
+    (name "rust-multipart")
+    (version "0.17.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "multipart" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1m3nrydgc56wjixsahipmvjgnxnw2cz7w8ryghsgahwjr3nswl6h"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-buf-redux" ,rust-buf-redux-0.8)
+        ("rust-clippy" ,rust-clippy-0.0)
+        ("rust-httparse" ,rust-httparse-1)
+        ("rust-hyper" ,rust-hyper-0.10)
+        ("rust-iron" ,rust-iron-0.6)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-mime" ,rust-mime-0.3)
+        ("rust-mime-guess" ,rust-mime-guess-2)
+        ("rust-nickel" ,rust-nickel-0.11)
+        ("rust-quick-error" ,rust-quick-error-1)
+        ("rust-rand" ,rust-rand-0.7)
+        ("rust-rocket" ,rust-rocket-0.4)
+        ("rust-safemem" ,rust-safemem-0.3)
+        ("rust-tempfile" ,rust-tempfile-3)
+        ("rust-tiny-http" ,rust-tiny-http-0.6)
+        ("rust-twoway" ,rust-twoway-0.1))
+       #:cargo-development-inputs
+        (("rust-env-logger" ,rust-env-logger-0.5))))))
+
 (define-public rust-nickel-0.11
   (package
     (name "rust-nickel")