summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:08:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:52 +0200
commit085b379d1ac336368f533a632b021f6d3e18c4ed (patch)
tree06290c59982bb5fedbd3606fbb686442b65fdd33
parenta5cd0e09929e46693ac121d152e079f6bc1bf9f4 (diff)
downloadguix-085b379d1ac336368f533a632b021f6d3e18c4ed.tar.gz
gnu: Add texlive-crosswrd.
* gnu/packages/tex.scm (texlive-crosswrd): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 095695fa97..f3be9a889d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4986,6 +4986,26 @@ separated by thick lines.
 @end itemize")
     (license license:expat)))
 
+(define-public texlive-crosswrd
+  (package
+    (name "texlive-crosswrd")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/crosswrd/"
+                   "source/latex/crosswrd/"
+                   "tex/latex/crosswrd/")
+             (base32
+              "0yhsrfn49wj579ms3smd1z97rjqnsi1wrsgrjs570bllgf09bcir")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/crosswrd")
+    (synopsis "Macros for typesetting crossword puzzles")
+    (description
+     "The package provides a LaTeX method of typesetting crosswords, and
+assists the composer ensure that the grid all goes together properly.")
+    (license license:lppl)))
+
 (define-public texlive-cryptocode
   (package
     (name "texlive-cryptocode")