summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 21:22:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:58 -0400
commit08a63ca93e76ed6fde37024ff522effbfdf0766d (patch)
treed867bcfd71491af403f226f3b26e3763981cae9d
parent3ce963254b8349c85157e9fcecc8e8afbe4236ac (diff)
downloadguix-08a63ca93e76ed6fde37024ff522effbfdf0766d.tar.gz
gnu: Remove python2-zeroconf.
* gnu/packages/python-xyz.scm (python2-zeroconf): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7601f45883..821c330670 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25069,42 +25069,6 @@ enumeration library in Python.")
 (Bonjour/Avahi compatible).")
     (license license:lgpl2.1+)))
 
-(define-public python2-zeroconf
-  (package
-    (name "python2-zeroconf")
-
-    ;; This is the last version that supports Python 2.x.
-    (version "0.19.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "zeroconf" version))
-       (sha256
-        (base32
-         "0ykzg730n915qbrq9bn5pn06bv6rb5zawal4sqjyfnjjm66snkj3"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-requires
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "setup.py"
-               (("enum-compat")
-                "enum34"))
-             #t)))))
-    (native-inputs
-     `(("python2-six" ,python2-six)
-       ("python2-enum32" ,python2-enum34)
-       ("python2-netifaces" ,python2-netifaces)
-       ("python2-typing" ,python2-typing)))
-    (home-page "https://github.com/jstasiak/python-zeroconf")
-    (synopsis "Pure Python mDNS service discovery")
-    (description
-     "Pure Python multicast DNS (mDNS) service discovery library (Bonjour/Avahi
-compatible).")
-    (license license:lgpl2.1+)))
-
 (define-public python-bsddb3
   (package
     (name "python-bsddb3")