summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-19 20:53:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-19 21:06:51 +0100
commit096589035ed154b6ecb4619ca8cdde208be1b8da (patch)
tree5c5eeb3698240fd45ffd6a9141533659b28b700e
parent51237011bfa1da1374fbd84581e337d6b54a5fc9 (diff)
downloadguix-096589035ed154b6ecb4619ca8cdde208be1b8da.tar.gz
gnu: bismark: Fix references to gunzip.
* gnu/packages/bioinformatics.scm (bismark)[arguments]: Keep reference to
gunzip executable.
[inputs]: Add gzip.
-rw-r--r--gnu/packages/bioinformatics.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a6dcc63bf3..af994c6a89 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11514,7 +11514,7 @@ Browser.")
          (delete 'configure)
          (delete 'build)
          (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((bin (string-append (assoc-ref outputs "out")
                                        "/bin"))
                    (docdir  (string-append (assoc-ref outputs "out")
@@ -11537,7 +11537,16 @@ Browser.")
                          scripts)
                (for-each (lambda (file) (install-file file docdir))
                          docs)
+               ;; Fix references to gunzip
+               (substitute* (map (lambda (file)
+                                   (string-append bin "/" file))
+                                 scripts)
+                 (("\"gunzip -c")
+                  (string-append "\"" (assoc-ref inputs "gzip")
+                                 "/bin/gunzip -c")))
                #t))))))
+    (inputs
+     `(("gzip" ,gzip)))
     (home-page "http://www.bioinformatics.babraham.ac.uk/projects/bismark/")
     (synopsis "Map bisulfite treated sequence reads and analyze methylation")
     (description "Bismark is a program to map bisulfite treated sequencing