summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-13 09:09:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-13 09:09:08 +0300
commit0b2d33af03a7bfca0b58dcd5c8d551eb6927cf6b (patch)
tree7edcd47bf3c90e02849d3138975af6c6b262589a
parent0433e7f3c200936fbf77f22aa3b433413d17d0fa (diff)
downloadguix-0b2d33af03a7bfca0b58dcd5c8d551eb6927cf6b.tar.gz
gnu: qgis: Allow building on more architectures.
* gnu/packages/geo.scm (qgis)[native-inputs]: Only build with shellcheck
on supported platforms.
-rw-r--r--gnu/packages/geo.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 6ad3c87ff1..65344bcac2 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2786,17 +2786,20 @@ growing set of geoscientific methods.")
            sqlite
            (list zstd "lib")))
     (native-inputs
-     (list bison
-           flex
-           perl
-           perl-yaml-tiny
-           pkg-config
-           python-mock
-           python-nose2
-           python-pyqt-builder
-           qttools-5
-           shellcheck
-           xorg-server-for-tests))
+     (append
+       (list bison
+             flex
+             perl
+             perl-yaml-tiny
+             pkg-config
+             python-mock
+             python-nose2
+             python-pyqt-builder
+             qttools-5)
+       (if (supported-package? shellcheck)
+         (list shellcheck)
+         '())
+       (list xorg-server-for-tests)))
     (home-page "https://qgis.org")
     (synopsis "Geographical information system")
     (description "QGIS is an easy to use Geographical Information