summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-20 15:57:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-21 00:44:04 -0400
commit0d774808542834b399838e1dba5be3186254b838 (patch)
tree0b23d306ff9fc34cc849f4392c81c1d662e0b42d
parent6bc285e6c6f055f38d77788648ce31352a7714a5 (diff)
downloadguix-0d774808542834b399838e1dba5be3186254b838.tar.gz
gnu: libnma: Remove patch-docbook-xml phase.
* gnu/packages/gnome.scm (libnma) [arguments]: Remove patch-docbook-xml
phase.  Use gexps.
[native-inputs]: Add libxml2.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 2c2de935ed..3eb7cb62a3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1748,23 +1748,16 @@ client devices can handle.")
     (arguments
      ;; GTK 4.x depends on Rust (indirectly) so pull it only on platforms
      ;; where it is supported.
-     `(#:configure-flags ,(if (supported-package? gtk)
-                              `(list "-Dlibnma_gtk4=true")
-                              `(list "-Dlibnma_gtk4=false"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-docbook-xml
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "libnma-docs.xml"
-               (("http://.*/docbookx\\.dtd")
-                (search-input-file
-                 inputs "xml/dtd/docbook/docbookx.dtd"))))))))
+     (list #:configure-flags (if (supported-package? gtk)
+                                 #~(list "-Dlibnma_gtk4=true")
+                                 #~(list "-Dlibnma_gtk4=false"))))
     (native-inputs
      (list docbook-xml-4.3
            gettext-minimal
            `(,glib "bin")
            gtk-doc/stable
            gobject-introspection
+           libxml2                      ;for XML_CATALOG_FILES
            pkg-config
            vala))
     (inputs