summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 22:45:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 22:48:42 +0100
commit0e5a981c2b688da3413daf84687fd18e8c02fda7 (patch)
treecbd12dface8fb6a1d7a61022260c3f681e1369bc
parentab8f3b1612e209181256afac23c2eb6775498c3a (diff)
downloadguix-0e5a981c2b688da3413daf84687fd18e8c02fda7.tar.gz
gnu: go-github-com-libp2p-go-libp2p-peer: Adjust inputs.
* gnu/packages/golang-crypto.scm (go-github-com-libp2p-go-libp2p-peer):
[propagated-inputs]: Swap from native-inputs to propagated-inputs to
access them from dependent packages.  Remove
go-github-com-mr-tron-base58, go-github-com-gxed-hashland-keccakpg,
go-github-com-minio-blake2b-simd, go-github-com-minio-sha256-simd,
go-github-com-spaolacci-murmur3; and go-golang-org-x-crypto.

Change-Id: Ib646c1a3eba7ad31fecc99578eedc5a3892e1af1
-rw-r--r--gnu/packages/golang-crypto.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index ffce530d7d..3b95965f6b 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -592,17 +592,11 @@ Stealing encryption and decryption methods.")
       (build-system go-build-system)
       (arguments
        '(#:import-path "github.com/libp2p/go-libp2p-peer"))
-      (native-inputs
+      (propagated-inputs
        (list go-github-com-btcsuite-btcd-btcec
              go-github-com-gogo-protobuf
-             go-github-com-gxed-hashland-keccakpg
              go-github-com-libp2p-go-libp2p-crypto
-             go-github-com-minio-blake2b-simd
-             go-github-com-minio-sha256-simd
-             go-github-com-mr-tron-base58
-             go-github-com-multiformats-go-multihash
-             go-github-com-spaolacci-murmur3
-             go-golang-org-x-crypto))
+             go-github-com-multiformats-go-multihash))
       (home-page "https://github.com/libp2p/go-libp2p-peer")
       (synopsis "PKI based identities for use in go-libp2p")
       (description "PKI based identities for use in @command{go-libp2p}.")