summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 09:52:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commit0f652cc404c6c2dffd86b0582bf9bf1fdab8ce38 (patch)
treecf820a542ea3cfec7e9e60e86f12ca8aa4ee653f
parentd610a77e88a1b329c895563173c1912135309928 (diff)
downloadguix-0f652cc404c6c2dffd86b0582bf9bf1fdab8ce38.tar.gz
gnu: go-github-com-mattn-go-sqlite3: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-sqlite3): Move from
here ...
* gnu/packages/golang-xyz.scm: ... to here.

* gnu/packages/file-systems.scm: Add (gnu packages golang-xyz) module.

Change-Id: If74972f1d920851a23508a6dc0403e0a84e270f3
-rw-r--r--gnu/packages/file-systems.scm1
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/golang.scm22
3 files changed, 26 insertions, 22 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 40f1383a56..8afd853350 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -76,6 +76,7 @@
   #:use-module (gnu packages golang-build)
   #:use-module (gnu packages golang-check)
   #:use-module (gnu packages golang-crypto)
+  #:use-module (gnu packages golang-xyz)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages jemalloc)
   #:use-module (gnu packages kerberos)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 62829a8715..06942a3647 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -14,6 +14,7 @@
 ;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
+;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 raingloom <raingloom@riseup.net>
 ;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
@@ -1921,6 +1922,30 @@ string.")
 the @code{cpan} module @code{Parse::CommandLine}.")
     (license license:expat)))
 
+(define-public go-github-com-mattn-go-sqlite3
+  (package
+    (name "go-github-com-mattn-go-sqlite3")
+    (version "1.14.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mattn/go-sqlite3")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "04anvqkc37mmc3z1dy4xfa6cas67zlxnnab0ywii7sylk864mhxz"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/mattn/go-sqlite3"))
+    (home-page "https://github.com/mattn/go-sqlite3")
+    (synopsis "Sqlite3 driver for Go")
+    (description
+     "This package provides a Sqlite3 driver for Go using
+@code{database/sql}.")
+    (license license:expat)))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ba358a02bb..1b138d8d0e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6601,28 +6601,6 @@ improved and cleaner API.")
 Proxy functionality.")
     (license license:expat)))
 
-(define-public go-github-com-mattn-go-sqlite3
-  (package
-    (name "go-github-com-mattn-go-sqlite3")
-    (version "1.14.6")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/mattn/go-sqlite3")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "04anvqkc37mmc3z1dy4xfa6cas67zlxnnab0ywii7sylk864mhxz"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/mattn/go-sqlite3"))
-    (home-page "https://github.com/mattn/go-sqlite3")
-    (synopsis "Sqlite3 driver for Go")
-    (description "This package provides a Sqlite3 driver for Go using
-@code{database/sql}.")
-    (license license:expat)))
-
 (define-public go-github-com-bits-and-blooms-bitset
   (package
     (name "go-github-com-bits-and-blooms-bitset")