summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-12 22:32:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:11 +0000
commit0fd36bed26cd82b6b1330d839422ee090b11a37d (patch)
tree45b1b01138f3d65e140b74e83b4df240a3b1cc73
parent18ac6a247ca213d8ec52db3d6623ecf9120f6e20 (diff)
downloadguix-0fd36bed26cd82b6b1330d839422ee090b11a37d.tar.gz
gnu: Add python-cmyt.
* gnu/packages/python-xyz.scm (python-cmyt): New variable.

Change-Id: I45caa38fc391fe7890f87f41b18d3cfa8da07c80
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index a898b98515..14b2c37343 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2056,6 +2056,31 @@ attempting to maintain ISTP compliance
 @end itemize")
     (license license:expat)))
 
+(define-public python-cmyt
+  (package
+    (name "python-cmyt")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cmyt" version))
+       (sha256
+        (base32 "1zabmckr1z637pfqqvlkj0asfqqvx2x92163dby8x0c8yiqgdvjb"))))
+    (build-system pyproject-build-system)
+    (native-inputs
+     (list python-colorspacious python-pytest python-pytest-mpl))
+    (propagated-inputs
+     (list python-matplotlib python-numpy))
+    (home-page "https://yt-project.org/")
+    (synopsis "Matplotlib colormaps from the yt project")
+    (description
+     "This package provides a range of colormaps designed for scientific
+use with Matplotlib.  It includes perceptually uniform sequential colormaps such
+as @code{abre}, @code{dusk}, @code{kepl}, and @code{octarine}, as well as
+monochromatic sequential colormaps like @code{blue}, @code{green}, and
+@code{red}, and others (@code{algae}, @code{pastel}, and @code{xray}).")
+    (license license:bsd-3)))
+
 (define-public python-crds
   (package
     (name "python-crds")