summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-14 13:55:21 -0700
committerBrian Leung <leungbk@mailfence.com>2019-10-14 14:08:40 -0700
commit100f3ccb736cdc77728af1f739ea82cc9da4b30c (patch)
tree28a1f05a5c048052373335f0732343fc8f6bab36
parent2322c9458cafa9519ca044f78720607de9838e88 (diff)
downloadguix-100f3ccb736cdc77728af1f739ea82cc9da4b30c.tar.gz
gnu: Add emacs-apheleia.
* gnu/packages/emacs-xyz.scm (emacs-apheleia): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 09ade9e493..9a80188699 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2420,6 +2420,28 @@ display and behaviour is easily customisable.")
 window.")
       (license license:gpl3+))))
 
+(define-public emacs-apheleia
+  (package
+    (name "emacs-apheleia")
+    (version "1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/raxod502/apheleia.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "04pls7zahy4jfkikv6fvd9vfpm4glhyanmmkx79hgi9pwdv966rf"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/raxod502/apheleia")
+    (synopsis "Reformat buffer stably")
+    (description
+     "This package allows for a buffer to be reformatted without moving point,
+so that running a formatting tool like @code{Prettier} or @code{Black} upon
+saving won't move point back to the beginning of the buffer.")
+    (license license:gpl3+)))
+
 (define-public emacs-git-timemachine
   (package
     (name "emacs-git-timemachine")