summary refs log tree commit diff
diff options
context:
space:
mode:
authorSkyler Ferris <skyvine@protonmail.com>2023-11-19 09:14:39 -0800
committerLudovic Courtès <ludo@gnu.org>2023-11-25 16:29:26 +0100
commit13bc0633e77c73389e530a4c45e2de5a823f106b (patch)
treec5899fc23eaa069c0188ab1452e7e6f471f1caee
parentc43077076f2e172ca89231affcfdf2dfaae0f351 (diff)
downloadguix-13bc0633e77c73389e530a4c45e2de5a823f106b.tar.gz
build-system/meson: Add #:substitutable? argument to build system.
This implemented the same as in gnu-build-system. The gexp->derivation
calls did not need to be modified because they already
passed #:substitutable?, which did not cause an error due to the
procedure exported by the (guix store) module with the same name.

* guix/build-system/meson.scm (meson-build, meson-cross-build): Add
  #:substitutable? argument

Change-Id: I2d56c8130f785a2d6af456ef9f9bfc1b10dc2a50
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--guix/build-system/meson.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 7c617bffb0..2d14016b94 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -182,6 +182,7 @@ TRIPLET."
                       (imported-modules %meson-build-system-modules)
                       (modules '((guix build meson-build-system)
                                  (guix build utils)))
+                      (substitutable? #t)
                       allowed-references
                       disallowed-references)
   "Build SOURCE using MESON, and with INPUTS, assuming that SOURCE
@@ -266,6 +267,7 @@ has a 'meson.build' file."
                             (imported-modules %meson-build-system-modules)
                             (modules '((guix build meson-build-system)
                                        (guix build utils)))
+                            (substitutable? #t)
                             allowed-references
                             disallowed-references)
   "Cross-build SOURCE for TARGET using MESON, and with INPUTS, assuming that