summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 15:23:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:57 +0200
commit1455678feb509e3f0d9cdc4e32b050207c6782f0 (patch)
treef2edc07f5c3242bdb1530ba2e644f1cb65433f97
parent9cbeada4a72e60c97f5c3762db27b84617ebd787 (diff)
downloadguix-1455678feb509e3f0d9cdc4e32b050207c6782f0.tar.gz
gnu: rust-orion-0.17: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-orion-0.17): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: Ic2ee47bffc0992fb9a58fb00b8b1412e9fc2ac83
-rw-r--r--gnu/packages/crates-crypto.scm34
-rw-r--r--gnu/packages/crates-io.scm34
2 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 68c2f531e3..10d7df870f 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1706,3 +1706,37 @@ cryptographic library.")
 cryptographic library.")
     (license ;; licensed under either of these, at your option
      (list license:lgpl3 license:gpl2 license:gpl3))))
+
+(define-public rust-orion-0.17
+  (package
+    (name "rust-orion")
+    (version "0.17.4")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "orion" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ri0b0vyd9vqwlzlcv0q4i7r9pga23q7nnnvd5z4zycjc9v4mryb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ct-codecs" ,rust-ct-codecs-1)
+        ("rust-fiat-crypto" ,rust-fiat-crypto-0.1)
+        ("rust-getrandom" ,rust-getrandom-0.2)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-subtle" ,rust-subtle-2)
+        ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.4)
+        ("rust-hex" ,rust-hex-0.4)
+        ("rust-quickcheck" ,rust-quickcheck-1)
+        ("rust-quickcheck-macros" ,rust-quickcheck-macros-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/orion-rs/orion")
+    (synopsis "Pure-Rust crypto")
+    (description
+     "Orion is a cryptography library written in pure Rust.  It aims to provide
+easy and usable crypto while trying to minimize the use of unsafe code.")
+    (license license:expat)))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 68a9d18ad4..427771367b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45673,40 +45673,6 @@ under its new name.")
      "This package provides a Rust library for parsing orgmode files.")
     (license license:expat)))
 
-(define-public rust-orion-0.17
-  (package
-    (name "rust-orion")
-    (version "0.17.4")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "orion" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0ri0b0vyd9vqwlzlcv0q4i7r9pga23q7nnnvd5z4zycjc9v4mryb"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-ct-codecs" ,rust-ct-codecs-1)
-        ("rust-fiat-crypto" ,rust-fiat-crypto-0.1)
-        ("rust-getrandom" ,rust-getrandom-0.2)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-subtle" ,rust-subtle-2)
-        ("rust-zeroize" ,rust-zeroize-1))
-       #:cargo-development-inputs
-       (("rust-criterion" ,rust-criterion-0.4)
-        ("rust-hex" ,rust-hex-0.4)
-        ("rust-quickcheck" ,rust-quickcheck-1)
-        ("rust-quickcheck-macros" ,rust-quickcheck-macros-1)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/orion-rs/orion")
-    (synopsis "Pure-Rust crypto")
-    (description
-     "Orion is a cryptography library written in pure Rust.  It aims to provide
-easy and usable crypto while trying to minimize the use of unsafe code.")
-    (license license:expat)))
-
 (define-public rust-os-info-3
   (package
     (name "rust-os-info")