summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:22:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:55 +0200
commit148b827dc391a3c5fc44b6878582a32a95b874b9 (patch)
tree8476202406df9e6c9c790e6509fcfc7721cbf4e2
parentd4c7d97764e863a0258df2d6dded4502475678e4 (diff)
downloadguix-148b827dc391a3c5fc44b6878582a32a95b874b9.tar.gz
gnu: Add texlive-nwejm.
* gnu/packages/tex.scm (texlive-nwejm): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eb5d0fc511..9649f72ceb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23481,6 +23481,31 @@ a normative format, as well as a hackable class for the users.  At present, it
 only supports XeTeX and LuaTeX engines.")
     (license license:lppl1.3c)))
 
+(define-public texlive-nwejm
+  (package
+    (name "texlive-nwejm")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/nwejm/" "source/latex/nwejm/"
+                   "tex/latex/nwejm/")
+             (base32
+              "16amdv0zzh9aax6c4adqai7zi2zknh168x4awsi1b8gbbspp2vbl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list  #:build-targets #~(list "nwejm.dtx")))
+    (home-page "https://ctan.org/pkg/nwejm")
+    (synopsis
+     "Support for the journal @emph{North-Western European Journal of
+Mathematics}")
+    (description
+     "The bundle includes LaTeX classes and BibLaTeX styles files dedicated to
+the new journal @emph{North-Western European Journal of Mathematics}:
+@code{nwejm} for the complete issues of the journal, aimed at the NWEJM's
+team, @code{nwejmart}, intended for the authors who wish to publish an article
+in the NWEJM.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-objectz
   (package
     (name "texlive-objectz")