summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-16 17:19:55 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-24 17:26:39 +0100
commit16c53a1e268a41d2d8c329b193d8bfb299490962 (patch)
treee1ee852466119ad062bceca40fb1cc03f7968726
parentfefedf98cb03971ec7b348c3b0468e1b77956f4a (diff)
downloadguix-16c53a1e268a41d2d8c329b193d8bfb299490962.tar.gz
gnu: Add r-org-dm-eg-db.
* gnu/packages/bioinformatics.scm (r-org-dm-eg-db): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 34590f1547..4f097f6d90 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4309,6 +4309,32 @@ annotations for the human genome.")
 annotations for the genome of the model worm Caenorhabditis elegans.")
     (license license:artistic2.0)))
 
+(define-public r-org-dm-eg-db
+  (package
+    (name "r-org-dm-eg-db")
+    (version "3.2.3")
+    (source (origin
+              (method url-fetch)
+              ;; We cannot use bioconductor-uri here because this tarball is
+              ;; located under "data/annotation/" instead of "bioc/".
+              (uri (string-append "http://www.bioconductor.org/packages/"
+                                  "release/data/annotation/src/contrib/"
+                                  "org.Dm.eg.db_" version ".tar.gz"))
+              (sha256
+               (base32
+                "0mib46c7nr00l7mh290n383za9hyl91a1dc6jhjbk884jmxaxyz6"))))
+    (properties
+     `((upstream-name . "org.Dm.eg.db")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)))
+    (home-page "http://www.bioconductor.org/packages/org.Dm.eg.db/")
+    (synopsis "Genome wide annotation for Fly")
+    (description
+     "This package provides mappings from Entrez gene identifiers to various
+annotations for the genome of the model fruit fly Drosophila melanogaster.")
+    (license license:artistic2.0)))
+
 (define-public r-qtl
  (package
   (name "r-qtl")