summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 21:39:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 21:39:06 +0000
commit170efe6e68e1f6ee24942b3031adee7c5000e3da (patch)
treef5f404568a2deab399c6ab672984ec4aa3d4d2e3
parent96895a65b41cc273e53cfb4665400671d83a046c (diff)
downloadguix-170efe6e68e1f6ee24942b3031adee7c5000e3da.tar.gz
gnu: python-crontab: Enable tests.
* gnu/packages/python-xyz.scm (python-crontab): Enable tests.
[arguments] <#:phases>: Add 'disable-failing-tests phase.

Change-Id: I294ff69091ed1ed6b016c194bc8fb6e5af11978c
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4aa0271de2..e5a6341f65 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27982,8 +27982,14 @@ format.")
         (base32 "0cccrqc10r8781ba81x8r2frs3pl2m4hkm599k5358ak0xr7xgjb"))))
     (build-system python-build-system)
     (arguments
-     ;; Comptability tests fail so they are disabled.
-     `(#:tests? #f))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'disable-failing-tests
+            (lambda _
+              (substitute* "tests/test_compatibility.py"
+                (("test_07_non_posix_shell")
+                 "__off_test_07_non_posix_shell")))))))
     (inputs
      (list python-dateutil))
     (home-page "https://gitlab.com/doctormo/python-crontab/")