summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-09-06 11:52:49 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-12 19:13:19 +0200
commit17bf4b1e80293864be329f553fb672c72a53e7fc (patch)
treef998acd1814e5df305b328f24791840bffb1a7c7
parent24b883916357cc15a10e650381e47e20fab0098f (diff)
downloadguix-17bf4b1e80293864be329f553fb672c72a53e7fc.tar.gz
gnu: pass-age: Wrap with coreutils-minimal.
* gnu/packages/password-utils.scm (pass-age):
  [arguments]<#:phases>: Add coreutils-minimal bin path to PATH.
  [inputs]: Replace git by git-minimal. Add coreutils-minimal.

Change-Id: I320adc9f412aa493a3bc83298f5d7ebe3d589458
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/password-utils.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index dc2ee27e29..bba9947638 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -785,6 +785,7 @@ through the pass command.")
                          (map (cut search-input-file inputs <>)
                               (list "bin/age"
                                     "bin/age-keygen"
+                                    "bin/cat"
                                     "bin/getopt"
                                     "bin/git"
                                     "bin/pkill"
@@ -798,7 +799,8 @@ through the pass command.")
          ("src/completion/pass.zsh-completion"
           "/share/zsh/site-functions/"))))
     (inputs
-     (list age age-keygen bash-minimal git procps qrencode sed tree util-linux))
+     (list age age-keygen coreutils-minimal git-minimal
+           procps qrencode sed tree util-linux))
     (home-page "https://github.com/FiloSottile/passage")
     (synopsis "Encrypted password manager")
     (description "This package provides an encrypted password manager, forked