summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-04-24 20:41:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-04-24 20:41:15 +0300
commit194d0d9843c515b4aa33a89994b64a583cf0a86a (patch)
treeec0d3cfcc1f8dbac41caab4f8f3f6dc09a1eeec5
parent59f151ec54fab4822cd0c41cfc99ed3614d67239 (diff)
downloadguix-194d0d9843c515b4aa33a89994b64a583cf0a86a.tar.gz
gnu: python2-itsdangerous: Use 'strip-python2-variant'.
* gnu/packages/python.scm (python2-itsdangerous): Use
'strip-python2-variant'.
[native-inputs]: Add python2-setuptools.
(python-itsdangerous)[inputs]: Remove python-setuptools.
[properties]: Define python2-variant.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 296f51ab59..4fbbb7ff2a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2401,17 +2401,21 @@ OAuth request-signing logic.")
         (base32
          "06856q6x675ly542ig0plbqcyab6ksfzijlyf1hzhgg3sgwgrcyb"))))
     (build-system python-build-system)
-    (inputs
-     `(("python-setuptools" ,python-setuptools)))
     (home-page "http://github.com/mitsuhiko/itsdangerous")
     (synopsis "Python library for passing data to/from untrusted environments")
     (description
      "Itsdangerous provides various helpers to pass trusted data to untrusted
 environments and back.")
-    (license bsd-3)))
+    (license bsd-3)
+    (properties `((python2-variant . ,(delay python2-itsdangerous))))))
 
 (define-public python2-itsdangerous
-  (package-with-python2 python-itsdangerous))
+  (let ((base (package-with-python2
+                (strip-python2-variant python-itsdangerous))))
+    (package
+      (inherit base)
+      (native-inputs `(("python2-setuptools" ,python2-setuptools)
+                       ,@(package-native-inputs base))))))
 
 (define-public python-pyyaml
   (package