summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-05-15 22:14:41 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:02 +0200
commit1b4733b77e71142695c36ca59eca632db1fd31b0 (patch)
tree1b05ee9e53d9e6281154f9875e01d68e6195db78
parent526f8b955ca9f4e3277379642b3f724c15f1bbc9 (diff)
downloadguix-1b4733b77e71142695c36ca59eca632db1fd31b0.tar.gz
gnu: libarchive: Ungraft.
* gnu/packages/backup.scm (libarchive)[replacement]: Remove.
[source]: Add ‘patches’.
(libarchive/fixed): Remove.

Change-Id: I32b717c2166a6683043e0169b96f383dc9404b96
-rw-r--r--gnu/packages/backup.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 8d7c9953a4..9b69873ced 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -260,7 +260,6 @@ backups (called chunks) to allow easy burning to CD/DVD.")
 (define-public libarchive
   (package
     (name "libarchive")
-    (replacement libarchive/fixed)
     (version "3.6.1")
     (source
      (origin
@@ -270,6 +269,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
                   (string-append "https://github.com/libarchive/libarchive"
                                  "/releases/download/v" version "/libarchive-"
                                  version ".tar.xz")))
+       (patches (search-patches "libarchive-remove-potential-backdoor.patch"))
        (sha256
         (base32
          "1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas"))))
@@ -349,25 +349,6 @@ random access nor for in-place modification.  This package provides the
 @command{bsdcat}, @command{bsdcpio} and @command{bsdtar} commands.")
     (license license:bsd-2)))
 
-(define-public libarchive/fixed
- (hidden-package
-  (package
-    (inherit libarchive)
-    (version "3.6.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (list (string-append "https://libarchive.org/downloads/libarchive-"
-                                 version ".tar.xz")
-                  (string-append "https://github.com/libarchive/libarchive"
-                                 "/releases/download/v" version "/libarchive-"
-                                 version ".tar.xz")))
-       (patches (search-patches "libarchive-remove-potential-backdoor.patch"))
-       (sha256
-        (base32
-         "1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas")))))))
-
-
 (define-public rdup
   (package
     (name "rdup")