summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-05-01 12:40:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-05-09 06:43:34 +0200
commit1b6f231c51df22b6689adb3d23499c79e1daebe4 (patch)
treef37043567f6fab301d080167c4a81206863d6a56
parent9cf0f714636cb9a21875f15c0172211d7def661e (diff)
downloadguix-1b6f231c51df22b6689adb3d23499c79e1daebe4.tar.gz
gnu: Add emacs-llm.
* gnu/packages/emacs-xyz.scm (emacs-llm): New variable.

Change-Id: Ie89eac7a4f0a31245b6d826ae9885a7092528ced
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 322448e62d..7eef10b856 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1606,6 +1606,27 @@ on stdout instead of using a socket as the Emacsclient does.")
 libgit2 bindings for Emacs, intended to boost the performance of Magit.")
       (license license:gpl2+))))
 
+(define-public emacs-llm
+  (package
+    (name "emacs-llm")
+    (version "0.13.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ahyatt/llm")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256 (base32
+                       "1q7djz4zx1br4d3g46f1m5cbxwl050qjmsm2cy7zcww64rrkcj0l"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/ahyatt/llm")
+    (synopsis "Emacs library abstracting Large Language Model capabilities.")
+    (description
+     "This package provides interfaces to abstract various @acronym{LLM, large
+language model}s out in the world.  To respect user freedom, it will warn you
+before interacting with non-free LLMs.")
+    (license license:gpl3+)))
+
 (define-public emacs-magit
     ;; Use this unreleased commit to benefit from a recent improvements with
     ;; regard to adding git trailers such as "Reviewed-by".