summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-23 14:04:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-23 20:39:13 +0300
commit1bfffc007aea291896a43f10114defe673c2bf5d (patch)
treee10d1497d868d5de93b2bd50c3edfcd5a34e83d8
parentc9730b7029087995a748e6c04dd810d7517fa966 (diff)
downloadguix-1bfffc007aea291896a43f10114defe673c2bf5d.tar.gz
gnu: gtk-vnc: Build with gjs on more architectures.
* gnu/packages/gnome.scm (gtk-vnc)[native-inputs] Use gjs as an input on
architectures where it is supported.

Change-Id: I723f53be8e225732572ede81a03d712a946be528
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a3b9799209..cb0f479a3f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9563,11 +9563,10 @@ like switching to windows and launching applications.")
      `(#:glib-or-gtk? #t))   ; To wrap binaries and/or compile schemas
     (native-inputs
      (append
-      ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
-      ;; dependency on other platforms (FIXME).
-       (if (target-x86-64?)
-           (list gjs)
-           '())
+      ;; GJS depends on Rust so remove the GJS dependency on other platforms.
+      (if (supported-package? gjs)
+          (list gjs)
+          '())
        (list gettext-minimal
              `(,glib "bin")
              gobject-introspection