summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 00:29:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:40:07 +0200
commit1dc24c1a585ae3fcd4382474d65532c88a954313 (patch)
tree7a7d4e96521e41f139fef3cd2a7c153026230382
parenta3ca86589430698dfcbface5e4f7db7d86172e6b (diff)
downloadguix-1dc24c1a585ae3fcd4382474d65532c88a954313.tar.gz
gnu: Add texlive-ordinalpt.
* gnu/packages/tex.scm (texlive-ordinalpt): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3e4e9be491..f7d4623b10 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6935,6 +6935,29 @@ easily available.  Especially, these symbols are used in scientific plots, but
 the potential user is allowed to use them in other ways.")
     (license license:lppl1.3+)))
 
+(define-public texlive-ordinalpt
+  (package
+    (name "texlive-ordinalpt")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ordinalpt/"
+                   "source/latex/ordinalpt/"
+                   "tex/latex/ordinalpt/")
+             (base32
+              "02hsl021gd23qrfm3myazg606lmp149dmpss3vyx93dyqcg8axbr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ordinalpt")
+    (synopsis "Counters as ordinal numbers in Portuguese")
+    (description
+     "The package provides a counter style (like @code{\\arabic},
+@code{\\alph} and others) which produces output strings like
+@samp{primeiro} (``first'' in Portuguese), @samp{segundo}, (``second''), and
+so on up to 1999th.  Separate counter commands are provided for different
+letter case variants, and for masculine and feminine gender inflections.")
+    (license license:lppl)))
+
 (define-public texlive-ot-tableau
   (package
     (name "texlive-ot-tableau")