summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-29 22:06:02 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-31 18:01:52 +0800
commit1dc8cdaa72b62232a69de8424e488c910ee58d21 (patch)
treebfbbb8e1d31cc32465fcd01ebd8fefe3492e629b
parent6609f2f4a7ea4b86424f101b0502f6aa1c2c88d4 (diff)
downloadguix-1dc8cdaa72b62232a69de8424e488c910ee58d21.tar.gz
gnu: vtk-7: Fix build.
* gnu/packages/patches/vtk-7-gcc-11-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/image-processing.scm (vtk-7)[source]: Add patch for gcc-11.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image-processing.scm3
-rw-r--r--gnu/packages/patches/vtk-7-gcc-11-compat.patch11
3 files changed, 14 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 48187d7e64..9b493df8d5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2085,6 +2085,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/vte-CVE-2012-2738-pt1.patch			\
   %D%/packages/patches/vte-CVE-2012-2738-pt2.patch			\
   %D%/packages/patches/vtk-7-gcc-10-compat.patch		\
+  %D%/packages/patches/vtk-7-gcc-11-compat.patch		\
   %D%/packages/patches/vtk-7-hdf5-compat.patch			\
   %D%/packages/patches/vtk-7-python-compat.patch		\
   %D%/packages/patches/wacomtablet-add-missing-includes.patch	\
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 4c7e97f85b..8fc93a8842 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -473,7 +473,8 @@ integrates with various databases on GUI toolkits such as Qt and Tk.")
                 "0nm7xwwj7rnsxjdv2ssviys8nhci4n9iiiqm2y14s520hl2dsp1d"))
               (patches (search-patches "vtk-7-python-compat.patch"
                                        "vtk-7-hdf5-compat.patch"
-                                       "vtk-7-gcc-10-compat.patch"))))
+                                       "vtk-7-gcc-10-compat.patch"
+                                       "vtk-7-gcc-11-compat.patch"))))
     (arguments
      (substitute-keyword-arguments (package-arguments vtk)
        ((#:configure-flags flags)
diff --git a/gnu/packages/patches/vtk-7-gcc-11-compat.patch b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
new file mode 100644
index 0000000000..c7ab3af36e
--- /dev/null
+++ b/gnu/packages/patches/vtk-7-gcc-11-compat.patch
@@ -0,0 +1,11 @@
+Description: GCC 11 now enforces that comparison objects be invocable as const.
+--- a/Rendering/Label/vtkLabelHierarchy.cxx
++++ b/Rendering/Label/vtkLabelHierarchy.cxx
+@@ -525,1 +525,1 @@
+-                    const vtkHierarchyNode & b)
++                    const vtkHierarchyNode & b) const
+--- a/Rendering/Label/vtkLabelHierarchyPrivate.h
++++ b/Rendering/Label/vtkLabelHierarchyPrivate.h
+@@ -66,1 +66,1 @@
+-    bool operator () ( const vtkIdType& a, const vtkIdType& b )
++    bool operator () ( const vtkIdType& a, const vtkIdType& b ) const