summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-23 10:07:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:30 +0200
commit217922f8a54ee932050af91081018477d2c8bd7f (patch)
tree6340a7ef739f96c4a53463c9a167517f341cc108
parent696e5bc49bc2ac6ea1e4cff7af69191d2074ab14 (diff)
downloadguix-217922f8a54ee932050af91081018477d2c8bd7f.tar.gz
gnu: Add texlive-morewrites.
* gnu/packages/tex.scm (texlive-morewrites): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6244e6a186..78a02b9389 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -35284,6 +35284,30 @@ advised to consider using the @code{fancyvrb} package in place of
 @code{moreverb}.")
     (license license:lppl)))
 
+(define-public texlive-morewrites
+  (package
+    (name "texlive-morewrites")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/morewrites/"
+                   "source/latex/morewrites/"
+                   "tex/latex/morewrites/")
+             (base32
+              "0vdpyzfzhb58q9fj8c4n23hb0day7gxm90ml5dsnizfn44g9nr2q")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/morewrites")
+    (synopsis "Always room for a new write stream")
+    (description
+     "The package aims to solve the error @emph{No room for a new \\write},
+which occurs when the user, or when the user's packages have allocated too
+many streams using @code{\\newwrite} (TeX has a fixed maximum number ---
+16 --- of such streams built-in to its code).  The package hooks into TeX
+primitive commands associated with writing to files; it should be loaded near
+the beginning of the sequence of loading packages for a document.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-morisawa
   (package
     (name "texlive-morisawa")