summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-13 12:10:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:18 +0200
commit2572bc812550eb6b881cddeeef3249fb6889cab6 (patch)
treec9cb288e102640eb54452c8baafaf7edfa5bd1a5
parent3bd962bc3c03d859ef8eacf52113d594d83a0815 (diff)
downloadguix-2572bc812550eb6b881cddeeef3249fb6889cab6.tar.gz
gnu: Add python-pygments-github-lexers.
* gnu/packages/python-xyz.scm (python-pygments-github-lexers): New variable.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a311d409c..3bfbe8373d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3735,6 +3735,25 @@ text styles of documentation.")
                  (base32
                   "1zmhnswy0wxfn0xprs9aqsvx2c3kmzfn2wx14q8cv3vpkxdamj4q")))))))
 
+(define-public python-pygments-github-lexers
+  (package
+    (name "python-pygments-github-lexers")
+    (version "0.0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pygments-github-lexers" version))
+       (sha256
+        (base32
+         "0cz14clcc9z4pn79ll8hp3xzgsrfjscak5zfsvlgrz6ngkkmgjma"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-pygments" ,python-pygments)))
+    (home-page "https://github.com/liluo/pygments-github-lexers")
+    (synopsis "Pygments Github custom lexers")
+    (description "This package installs Github custom lexers to Pygments.")
+    (license license:bsd-3)))
+
 (define-public python-bump2version
   (package
     (name "python-bump2version")