summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:02:44 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:19 -0400
commit25ed723d5e0ebbbad84271ed9b6cf723cc67cff6 (patch)
tree30b040c1d2898b27aa0b71af5c4878cfaecd31a3
parent7f3aec372a6122ad06d3f8ac620e101891a6f4c3 (diff)
downloadguix-25ed723d5e0ebbbad84271ed9b6cf723cc67cff6.tar.gz
gnu: Remove python2-pyroute2.
* gnu/packages/python-xyz.scm (python2-pyroute2): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93100f6366..b535610245 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11928,41 +11928,6 @@ reading and writing MessagePack data.")
 and MAC network addresses.")
     (license license:bsd-3)))
 
-(define-public python2-pyroute2
-  (package
-    (name "python2-pyroute2")
-    (version "0.5.6")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "pyroute2" version))
-       (sha256
-        (base32
-         "1gmz4r1w0yzj6fjjypnalmfyy0lnfznydyn62gi3wk50j5hhxbny"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2))                       ;Python 3.x is not supported
-    (home-page "https://github.com/svinota/pyroute2")
-    (synopsis "Python netlink library")
-    (description
-     "Pyroute2 is a pure Python netlink library with minimal dependencies.
-Supported netlink families and protocols include:
-@itemize
-@item rtnl, network settings - addresses, routes, traffic controls
-@item nfnetlink - netfilter API: ipset, nftables, ...
-@item ipq - simplest userspace packet filtering, iptables QUEUE target
-@item devlink - manage and monitor devlink-enabled hardware
-@item generic - generic netlink families
-  @itemize
-  @item nl80211 - wireless functions API (basic support)
-  @item taskstats - extended process statistics
-  @item acpi_events - ACPI events monitoring
-  @item thermal_events - thermal events monitoring
-  @item VFS_DQUOT - disk quota events monitoring
-  @end itemize
-@end itemize")
-    (license license:gpl2+)))
-
 (define-public python-wrapt
   (package
     (name "python-wrapt")