summary refs log tree commit diff
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2023-05-11 23:55:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-11 23:55:43 +0200
commit277c24442c323bbf5523e0024f868fc596a5cc60 (patch)
tree3d3dc1b00affa55385880bd6605291f2d735767a
parent60cf9866cfd01bd0492bdc427a016e26d779bb4e (diff)
downloadguix-277c24442c323bbf5523e0024f868fc596a5cc60.tar.gz
gnu: Add emacs-framemove.
* gnu/packages/emacs-xyz.scm (emacs-framemove): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a5d1453398..f69967287d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -129,6 +129,7 @@
 ;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
 ;;; Copyright © 2022-2023 Simon Josefsson <simon@josefsson.org>
+;;; Copyright © 2023 Fabio Natali <me@fabionatali.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32498,6 +32499,30 @@ such as:
 @end itemize")
     (license license:gpl3+)))
 
+(define-public emacs-framemove
+  ;; Use the latest commit, as there are no tagged releases.
+  (let ((commit "0faa8a4937f398e4971fc877b1c294100506b645")
+        (revision "0"))
+    (package
+      (name "emacs-framemove")
+      (version (git-version "0.10" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsmirror/framemove")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1z4xqx1cvllil03pdwsybsj5v9w7ggdrak1kxa856ki5mj1ja3gl"))))
+      (build-system emacs-build-system)
+      (home-page "https://www.emacswiki.org/emacs/framemove.el")
+      (synopsis "Directional frame selection routines")
+      (description "Framemove is similar to the Windmove library, but for
+frames.  It provides a simple set of keystrokes to move the input/focus
+between windows.")
+      (license license:gpl3))))
+
 (define-public emacs-flycheck-cpplint
   (package
     (name "emacs-flycheck-cpplint")