summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-18 18:49:15 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-23 20:44:35 +0100
commit3f544cf207b1d7aafdb500b26900fcba4cfe8fa4 (patch)
tree80d88557333f5cc1a50b1940eeddbe5013e68c41
parent128c82bb3961ff74ff5b5fcac7c75b87fdee9336 (diff)
downloadguix-3f544cf207b1d7aafdb500b26900fcba4cfe8fa4.tar.gz
gnu: OpenSSL: Remove obsolete phase.
* gnu/packages/tls.scm (openssl)[arguments]: Remove 'make-libraries-writable' phase.
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 0 insertions, 10 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f4ae7fbda3..8813083302 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -318,16 +318,6 @@ required structures.")
                                     "/share/openssl-" ,version)
 
                      (string-append "--prefix=" out)))))
-        (add-after
-         'install 'make-libraries-writable
-         (lambda* (#:key outputs #:allow-other-keys)
-           ;; Make libraries writable so that 'strip' does its job.
-           (let ((out (assoc-ref outputs "out")))
-             (for-each (lambda (file)
-                         (chmod file #o644))
-                       (find-files (string-append out "/lib")
-                                   "\\.so"))
-             #t)))
         (add-after 'install 'move-static-libraries
           (lambda* (#:key outputs #:allow-other-keys)
             ;; Move static libraries to the "static" output.