summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 11:22:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:44 +0100
commit4117a463dc477561eed3ac6903c8fd71f5cebbe4 (patch)
tree5132bae77d41442c8f22edfb85e0f3041e0d83ee
parent6533ff252a4a6ac07d7b064bfb27e9ace4515774 (diff)
downloadguix-4117a463dc477561eed3ac6903c8fd71f5cebbe4.tar.gz
gnu: Add go-github-com-tkuchiki-go-timezone.
* gnu/packages/golang-xyz.scm (go-github-com-tkuchiki-go-timezone): New variable.

Change-Id: Iab9a96c7a8224b5c0b7dbcab75dcc4dcf45e5699
-rw-r--r--gnu/packages/golang-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 23712d6fd8..b82e96045e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2723,6 +2723,38 @@ well as a program to generate applications and command files.")
 query information regarding the number of CPUs available to the system.")
     (license license:asl2.0)))
 
+(define-public go-github-com-tkuchiki-go-timezone
+  (package
+    (name "go-github-com-tkuchiki-go-timezone")
+    (version "0.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tkuchiki/go-timezone")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1rmvg4hh0br51vbsxacani2g0v5xxsayp8q4xli9jag25zi5rhd1"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/tkuchiki/go-timezone"))
+    (home-page "https://github.com/tkuchiki/go-timezone")
+    (synopsis "Timezone utility for Golang")
+    (description
+     "This package provides provides an utility for timezone manipulation,
+implementing the following features:
+
+@itemize
+@item this library uses only the standard package
+@item supports getting offset from timezone abbreviation, which is not
+supported by the time package
+@item determine whether the specified time.Time is daylight saving time
+@item change the location of time.Time by specifying the timezone
+@end itemize")
+    (license license:expat)))
+
 (define-public go-github-com-vividcortex-ewma
   (package
     (name "go-github-com-vividcortex-ewma")