summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 11:46:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:52 +0000
commit427bb76c47619d663e90b7eeefd1118c2faeb66b (patch)
tree9472b3a55f90f0e406aa0c62315ed207110afe5f
parent8c9d95a47cbf1ec77844a6050873aaed273e2a76 (diff)
downloadguix-427bb76c47619d663e90b7eeefd1118c2faeb66b.tar.gz
gnu: Add go-github-com-aead-ecdh.
* gnu/packages/golang-crypto.scm (go-github-com-aead-ecdh): New variable.

Change-Id: I50ddf2453834d8928be2301715fd6c207de5a536
-rw-r--r--gnu/packages/golang-crypto.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 9a845612a3..d221f78596 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -267,6 +267,34 @@ Bernstein.  The most common ChaCha variant is ChaCha20 (20 rounds).  ChaCha20
 is standardized in RFC 7539.")
       (license license:expat))))
 
+(define-public go-github-com-aead-ecdh
+  (package
+    (name "go-github-com-aead-ecdh")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/aead/ecdh")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b0ps5wzm0q0skzikp91l8slgaw5s9z42g4wnmc69am5gw7h4mpd"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/aead/ecdh"))
+    (propagated-inputs
+     (list go-golang-org-x-crypto))
+    (home-page "https://github.com/aead/ecdh")
+    (synopsis "Elliptic Cureves Deffie-Hellman key exchange implementation in Golang")
+    (description
+     "Package ecdh implements the Diffie-Hellman key exchange using elliptic
+curves (ECDH).  It directly provides ECDH implementations for the NIST curves
+P224, P256, P384, and Bernstein's Cruve25519.  The same logic is available in
+Go 1.20 @code{crypto/ecdh} standard package.")
+    (license license:expat)))
+
 (define-public go-github-com-aperturerobotics-jacobsa-crypto
   (let ((commit "b1eb679742a8deed015a4406384eea6bd985d08a")
         (revision "0"))