summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 15:00:22 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-19 15:04:54 +0100
commit445013b69da3d2eb10ebb145d5d55ee62aa155ed (patch)
treeca6d324c8ab42d935bdf201b4a0634e725c85775
parenta21d9b8d5c15f200f3c71cfb86207dbefcff6c80 (diff)
downloadguix-445013b69da3d2eb10ebb145d5d55ee62aa155ed.tar.gz
gnu: isc-dhcp: Fix cross-compilation.
* gnu/packages/admin.scm (isc-dhcp)[arguments]: Add a configure flag to
specify randomdev path, which is needed when cross-compiling. Also add a
fix-bind-cross-compilation phase.
-rw-r--r--gnu/packages/admin.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 820798b87c..6368289563 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -29,6 +29,7 @@
 ;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -776,6 +777,7 @@ connection alive.")
       (build-system gnu-build-system)
       (arguments
        `(#:parallel-build? #f
+         #:configure-flags '("--with-randomdev=/dev/random")
          #:phases
          (modify-phases %standard-phases
            (add-after 'unpack 'replace-bundled-bind
@@ -807,6 +809,12 @@ connection alive.")
                  (("^RELEASEVER=.*")
                   (format #f "RELEASEVER=~a\n" ,bind-release-version)))
                #t))
+           (add-before 'configure 'fix-bind-cross-compilation
+             (lambda _
+               (substitute* "configure"
+                 (("--host=\\$host")
+                  "--host=$host_alias"))
+               #t))
            (add-after 'configure 'post-configure
              (lambda* (#:key outputs #:allow-other-keys)
                ;; Point to the right client script, which will be