summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 03:56:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 04:36:51 +0200
commit44da87334da74cbbeb20e5819c767fc886cf7aac (patch)
treec112b1b9b7e7dc31a6a2c32927e7e2fce940c557
parent110888f85f21df6922d4042926d25c567fa0d966 (diff)
downloadguix-44da87334da74cbbeb20e5819c767fc886cf7aac.tar.gz
gnu: electron-cash: Fix share/ location.
* gnu/packages/finance.scm (electron-cash)[arguments]: Drop bogus
‘local/share’ subdirectory: rename ‘patch-home’ to
‘create-output-directories’ and adjust body to match.
-rw-r--r--gnu/packages/finance.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 6ffdff5d6e..12da4225dc 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -517,11 +517,10 @@ other machines/servers.  Electrum does not download the Bitcoin blockchain.")
                            (guix build qt-utils))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'patch-home
+         (add-after 'unpack 'create-output-directories
            (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "setup.py"
-               (("~/.local/share")
-                (string-append (assoc-ref outputs "out") "/local/share")))
+             ;; setup.py installs to ~/.local/share if this doesn't exist.
+             (mkdir-p (string-append (assoc-ref outputs "out") "/share"))
              #t))
          (add-after 'unpack 'use-libsecp256k1-input
            (lambda* (#:key inputs #:allow-other-keys)