summary refs log tree commit diff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-11-07 03:33:40 +0300
committerLudovic Courtès <ludo@gnu.org>2024-11-12 23:48:31 +0100
commit45a594a9647d40f188744f67180a4e3e6fc7899b (patch)
treeba40b34b012cf0b25d8758807a815bfa4e83a136
parentf7a0be4d736a56403fd9bd630dc723f59f348453 (diff)
downloadguix-45a594a9647d40f188744f67180a4e3e6fc7899b.tar.gz
gnu: sway: Update to 1.10.
* gnu/packages/wm.scm (sway): Update to 1.10.
[inputs] Replace wlroots-0.17 with wlroots.

Change-Id: Ia5230c58ecb11e3b1e5a94557f2965d7e648851f
Reviewed-by: Mazin Alhaddad <mazin@getstate.dev>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wm.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 836d4b6c04..b8c47d0317 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1906,7 +1906,7 @@ narrow the items to those matching the tokens in the input.")
 (define-public sway
   (package
     (name "sway")
-    (version "1.9")
+    (version "1.10")
     (source
      (origin
        (method git-fetch)
@@ -1915,7 +1915,7 @@ narrow the items to those matching the tokens in the input.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1n36vgpi4bg2gkiq4fam4khly1z9bjinmjclzq5vfx0z8h7a5bzz"))))
+        (base32 "0f8mdvpv9w44r91944s90s0cssqvgmnhi4zxn4xa4xllg3z98drz"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -1943,7 +1943,7 @@ narrow the items to those matching the tokens in the input.")
                   pcre2
                   swaybg
                   wayland
-                  wlroots-0.17))
+                  wlroots))
     (native-inputs
      (cons* linux-pam mesa pkg-config scdoc wayland-protocols
             (if (%current-target-system)