summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 11:37:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:56 +0000
commit47dfe96eb6c8e1a24d558fbd29a157ee5f909584 (patch)
treeb65247c2f26f628870064e12eafdaf63eb90c9fe
parentd8717abb49f9e7dbb2cd473e441b109712dc2478 (diff)
downloadguix-47dfe96eb6c8e1a24d558fbd29a157ee5f909584.tar.gz
gnu: run: Update to 0.11.2.
* gnu/packages/task-runners.scm (run): Update to 0.11.2. Adjust package
style by shiftin order of fields.
[arguments]: Do not install sources.
[propagated-inputs]: Remove go-github-com-tekwizely-go-parsing.
[native-inputs]: Add go-github-com-goreleaser-fileglob,
go-github-com-subosito-gotenv, and
go-github-com-tekwizely-go-parsing.

Change-Id: I02e4384aee83a3000c159e9d74fe1e94505ce9a7
-rw-r--r--gnu/packages/task-runners.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/task-runners.scm b/gnu/packages/task-runners.scm
index f06658fd7d..eb64f432e8 100644
--- a/gnu/packages/task-runners.scm
+++ b/gnu/packages/task-runners.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,7 +34,7 @@
 (define-public run
   (package
     (name "run")
-    (version "0.7.2")
+    (version "0.11.2")
     (source
      (origin
        (method git-fetch)
@@ -42,17 +43,21 @@
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "17n11lqhywq4z62w2rakdq80v7mxf83rgln19vj4v4nxpwd2hjjw"))))
+        (base32 "1p9hyc3zrjh58nqdc2j2qnkcyg7z8av2q7fb49ycs4292awl0zka"))))
     (build-system go-build-system)
-    (propagated-inputs
-     (list go-github-com-tekwizely-go-parsing))
     (arguments
-     `(#:import-path "github.com/tekwizely/run"))
+     (list
+      #:install-source? #f
+      #:import-path "github.com/tekwizely/run"))
+    (native-inputs
+     (list go-github-com-goreleaser-fileglob
+           go-github-com-subosito-gotenv
+           go-github-com-tekwizely-go-parsing))
+    (home-page "https://github.com/TekWizely/run")
     (synopsis "Easily manage and invoke small scripts and wrappers")
     (description
      "Run is a tool to easily manage and invoke small scripts and wrappers by
 using a Runfile.")
-    (home-page "https://github.com/TekWizely/run")
     (license license:expat)))
 
 (define-public task-spooler