summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-19 10:39:23 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-26 21:16:42 +0900
commit4818404bb41687249d9a7004cf350575de9970ab (patch)
treeb50f9443fec7a3aad8280abdbeb726d99e30c9df
parent3581d9d3bdf741f9231a415d8b22cf42d9ba9f13 (diff)
downloadguix-4818404bb41687249d9a7004cf350575de9970ab.tar.gz
gnu: emacs-org-texlive-collection: Reduce closure.
Based on feedback received by Nicolas Goaziou.  Thank you!

* gnu/packages/emacs-xyz.scm (emacs-org-texlive-collection): Do not inherit
from emacs-org.
[version]: Explicitly set to that of emacs-org.
[inputs]: Remove texlive-amsmath, texlive-graphics, texlive-hypperef,
texlive-titling, texlive-tools.
Replace texlive-scheme-small by texlive-collection-latexrecommended.  Add
texlive-soul and texlive-standalone.
[synopsis, description]: Fix TeX Live and Org mode spelling.
[home-page]: Explicitly set to that of emacs-org.
[license]: Use the TeX Live license, as this is a TeX Live collection
meta-package.

Suggested-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Change-Id: Id898f0cde5d805ee9262b5ded0d47f307b73f005
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cfedbb01a9..05077d331d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17700,26 +17700,27 @@ compatible with the Org stable version.")
 
 (define-public emacs-org-texlive-collection
   (package
-    (inherit emacs-org)
     (name "emacs-org-texlive-collection")
     (source #f)
+    (version (package-version emacs-org))
     (build-system trivial-build-system)
     (arguments (list #:builder #~(mkdir #$output)))
     (native-inputs '())
     (inputs '())
     (propagated-inputs
-     (list texlive-amsmath
-           texlive-capt-of
-           texlive-graphics             ;for graphicx, rotating
-           texlive-hyperref
-           texlive-titling
-           texlive-tools                ;for longtable
+     (list texlive-capt-of
+           ;; The latexrecommended collection provides fontspec, amsmath,
+           ;; hyperref, graphicx, tools, etc.
+           texlive-collection-latexrecommended
+           texlive-soul
+           texlive-standalone
            texlive-ulem
-           texlive-wrapfig
-           texlive-scheme-small))      ;for amsfonts, fontspec, inputenc, etc.
-    (synopsis "Basic TexLive packages for Org-mode LaTeX export")
-    (description "This meta-package propagates the TexLive packages minimally
-required by the Org-mode produced LaTeX output.")))
+           texlive-wrapfig))
+    (home-page (package-home-page emacs-org))
+    (synopsis "Basic TeX Live packages for Org mode LaTeX export")
+    (description "This meta-package propagates the TeX Live packages minimally
+required by the LaTeX output produced by Org mode.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
 (define-public emacs-org-contacts
   ;; XXX: Upstream does not tag version bumps. Commit below matches latest