summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:36:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:38 +0200
commit4b07c2a1779e2ee3b3e7e41a136f54550f382b07 (patch)
tree201c98d04053132b133b58f42cefd1b15dbc2abf
parent283c2c258df4641dfc534537e740de3f3e94a51f (diff)
downloadguix-4b07c2a1779e2ee3b3e7e41a136f54550f382b07.tar.gz
gnu: Add texlive-musicography.
* gnu/packages/tex.scm (texlive-musicography): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f906cf2234..3eae6832df 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9922,6 +9922,29 @@ more.  It gracefully handles dialog that crosses page breaks, and can generate
 lists of songs and lists of dances in the show.")
     (license license:lppl1.3+)))
 
+(define-public texlive-musicography
+  (package
+    (name "texlive-musicography")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/musicography/"
+                   "tex/latex/musicography/")
+             (base32
+              "07z5yg0ganmmp3qx5v55ll82sf45x6mhjl59abc5xckkfrgixpxn")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/musicography")
+    (synopsis "Accessing symbols for music writing with pdfLaTeX")
+    (description
+     "This package makes available the most commonly used symbols in writing
+about music in a way that can be used with pdfLaTeX and looks consistent and
+attractive.  It includes accidentals, meters, and notes of different rhythmic
+values.  The package builds on the approach used in the @code{harmony}
+package, where the symbols are taken from the MusiXTeX fonts.  But it provides
+a larger range of symbols and a more flexible, user-friendly interface.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-musixtex
   (package
     (name "texlive-musixtex")