summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 10:03:09 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:14 +0200
commit4b185ecc3cd87315f01781ca9d9f21f9a8eae9c4 (patch)
treea3a0b872b7b69e332bd32b3b7a961afcfe803a0c
parent6180193a2f8ebeb9e1e821db179a91628ad04d8c (diff)
downloadguix-4b185ecc3cd87315f01781ca9d9f21f9a8eae9c4.tar.gz
gnu: Add rust-futures-executor-preview-0.3.
* gnu/packages/crates-io.scm (rust-futures-executor-preview-0.3): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d406f276d1..b15ce0d215 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1331,6 +1331,36 @@ the computation on the threads themselves.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-futures-executor-preview-0.3
+  (package
+    (name "rust-futures-executor-preview")
+    (version "0.3.0-alpha.17")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "futures-executor-preview" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "053g5kf2qa1xhdkwp3d1grrizzy4683mpbb3y0vvm00hwl7jdfl7"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-futures-channel-preview" ,rust-futures-channel-preview-0.3)
+        ("rust-futures-core-preview" ,rust-futures-core-preview-0.3)
+        ("rust-futures-util-preview" ,rust-futures-util-preview-0.3)
+        ("rust-num-cpus" ,rust-num-cpus-1.10)
+        ("rust-pin-utils" ,rust-pin-utils-0.1))))
+    (home-page "https://github.com/rust-lang/futures-rs")
+    (synopsis
+     "Executors for asynchronous tasks based on futures-rs")
+    (description
+     "Executors for asynchronous tasks based on the futures-rs
+library.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-futures-io-preview-0.3
   (package
     (name "rust-futures-io-preview")