summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 23:05:59 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 23:06:18 +0100
commit4b9bb8e794d532a166fb2a9eb52b5fb2afb1581f (patch)
tree91775ca9f32aec099986c448f4d3331c7d5f55b1
parent89405ff470c98f8e06af22124b92b2d8080bb047 (diff)
downloadguix-4b9bb8e794d532a166fb2a9eb52b5fb2afb1581f.tar.gz
gnu: Add go-github-com-ipfs-go-ipfs-redirects-file.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-redirects-file): New variable.

Change-Id: I15876b3cd4ef58191e628bd08bc855ab4aafcdf1
-rw-r--r--gnu/packages/ipfs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 3978ff394b..662b2ea9a1 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -391,6 +391,35 @@ throughout its lifetime.")
      "@code{go-ipfs-exchange-interface} defines the IPFS exchange interface.")
     (license license:expat)))
 
+(define-public go-github-com-ipfs-go-ipfs-redirects-file
+  (package
+    (name "go-github-com-ipfs-go-ipfs-redirects-file")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ipfs/go-ipfs-redirects-file")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16lisd5jbniang85jzfwfigw0kmz73913fsrfj49nh92mpw50qpz"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/ipfs/go-ipfs-redirects-file"))
+    (native-inputs
+     (list go-github-com-tj-assert))
+    (propagated-inputs
+     (list go-github-com-pkg-errors
+           go-github-com-ucarion-urlpath))
+    (home-page "https://github.com/ipfs/go-ipfs-redirects-file")
+    (synopsis "IPFS Web Gateway _redirects file format parser")
+    (description
+     "Package redirects provides Netlify style _redirects file format
+parsing.")
+    (license license:expat)))
+
 (define-public go-github-com-ipfs-go-ipfs-util
   (package
     (name "go-github-com-ipfs-go-ipfs-util")