summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-05-08 22:28:47 +0200
committerJelle Licht <jlicht@fsfe.org>2023-05-08 22:28:47 +0200
commit50249cab3a98839ade2433456fe618acc6f804a5 (patch)
treee0b98f5f3cbfe062d9c550e27c74d63e66f75372
parent5f024ef3afd09fb1b5e6b067a02347d79d3bed41 (diff)
downloadguix-50249cab3a98839ade2433456fe618acc6f804a5.tar.gz
gnu: foot: Add search path for 'TERMINFO_DIRS'.
* gnu/packages/terminals.scm (foot)[native-search-paths]: New field.
-rw-r--r--gnu/packages/terminals.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 23224b608b..513fa8c563 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -862,6 +862,12 @@ eye-candy, customizable, and reasonably lightweight.")
     (native-inputs
      (list ncurses ;for 'tic'
            pkg-config scdoc wayland-protocols))
+    (native-search-paths
+     ;; FIXME: This should only be located in 'ncurses'.  Nonetheless it is
+     ;; provided for usability reasons.  See <https://bugs.gnu.org/22138>.
+     (list (search-path-specification
+            (variable "TERMINFO_DIRS")
+            (files '("share/terminfo")))))
     (inputs
      (list fcft libxkbcommon wayland))
     (synopsis "Wayland-native terminal emulator")