summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-07 00:56:43 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-07 00:56:43 +0100
commit516277cb146b528a3686c5d7d5ce0bd349095af3 (patch)
tree1677c8c7246f99e8d2773d0a92296ec038941e3d
parentf944fbf185a869845fe3eb78977a118b1ef593cc (diff)
downloadguix-516277cb146b528a3686c5d7d5ce0bd349095af3.tar.gz
gnu: python2-pil: Adapt to newer Freetype.
* gnu/packages/python.scm (python2-pil): Add snippet.
-rw-r--r--gnu/packages/python.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 58132b334a..c28d389f88 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3146,7 +3146,14 @@ libxml2 and libxslt.")
               version ".tar.gz"))
         (sha256
           (base32
-            "04aj80jhfbmxqzvmq40zfi4z3cw6vi01m3wkk6diz3lc971cfnw9"))))
+            "04aj80jhfbmxqzvmq40zfi4z3cw6vi01m3wkk6diz3lc971cfnw9"))
+       (modules '((guix build utils)))
+       (snippet
+        ;; Adapt to newer freetype. As the package is unmaintained upstream,
+        ;; there is no use in creating a patch and reporting it.
+        '(substitute* "_imagingft.c"
+           (("freetype/")
+            "freetype2/")))))
     (build-system python-build-system)
     (inputs
       `(("freetype" ,freetype)