summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-06-26 20:40:21 +0200
committerJohn Darrington <jmd@gnu.org>2014-06-27 17:53:40 +0200
commit51d3dcea42f570d3d44af701e0c09ef1d1bfcea0 (patch)
tree13f0c351f84a0f8e4af539f0191d9a07c35baf8a
parente55354b87eae085105b1d89eebcab0755e81d4c9 (diff)
downloadguix-51d3dcea42f570d3d44af701e0c09ef1d1bfcea0.tar.gz
gnu: Add qrencode.
* gnu/packages/aidc.scm (qrencode): New variable.
-rw-r--r--gnu/packages/aidc.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index f41a9aa55f..b033255028 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -22,6 +22,8 @@
                 #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages libpng)
   #:use-module (guix build-system gnu))
 
 
@@ -43,3 +45,25 @@ measurements.  Barcodes can be output in PostScript or Encapsulated PostScript
 formats.")
     (license license:gpl3+)
     (home-page "http://www.gnu.org/software/barcode/")))
+
+(define-public qrencode
+  (package
+    (name "qrencode")
+    (version "3.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://fukuchi.org/works/qrencode/qrencode-" version
+                    ".tar.bz2")) 
+              (sha256 (base32
+                       "163sb580p570p27imc6jhkfdw15kzp8vy1jq92nip1rwa63i9myz"))))
+    (build-system gnu-build-system)
+    (inputs `(("libpng" ,libpng)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (synopsis "Encode data into a QR Code symbol")
+    (description "Libqrencode is a C library for encoding data in a QR Code
+symbol, a kind of 2D symbology that can be scanned by handy terminals such as
+a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
+characters, and is highly robust.")
+    (license license:lgpl2.1+)
+    (home-page "http://fukuchi.org/works/qrencode")))