summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-12 21:42:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-26 18:13:25 +0300
commit541b45ce603834feb26061d16aef2180dede7220 (patch)
tree873c209d93290591f88aa82d50154aacce87e86c
parent4fcbb5787ccc0ad6818fda6faba92afed297da00 (diff)
downloadguix-541b45ce603834feb26061d16aef2180dede7220.tar.gz
gnu: pass-age: Update shell completion directories.
* gnu/packages/password-utils.scm (pass-age)[arguments]: Adjust the
install-plan to adjust the shell completion directories.

Change-Id: I5153dd4c9e88d05c22f4ddda135704a7bfe3cc81
-rw-r--r--gnu/packages/password-utils.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index bba9947638..dcd155835a 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -795,9 +795,11 @@ through the pass command.")
        #:install-plan
        '(("src/passage" "/bin/")
          ("src/completion/pass.bash-completion"
-          "/share/bash-completion/completions/")
+          "/etc/bash-completion.d/passage")
+         ("src/completion/pass.fish-completion"
+          "/share/fish/vendor_completions.d/passage")
          ("src/completion/pass.zsh-completion"
-          "/share/zsh/site-functions/"))))
+          "/share/zsh/site-functions/_passage"))))
     (inputs
      (list age age-keygen coreutils-minimal git-minimal
            procps qrencode sed tree util-linux))