summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-15 15:31:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-15 15:31:41 +0300
commit57629484b0bbedf65b52ea1b832c37aae4ac26da (patch)
treed454d437bbd9234d376bde2d1a69086ccf53f571
parent8bfc8ffb82ce80b8d069c1408cf89198935b7e58 (diff)
downloadguix-57629484b0bbedf65b52ea1b832c37aae4ac26da.tar.gz
gnu: python-numpy: Fix buidling on powerpc64le-linux.
Reported by mrvdb- on IRC.

* gnu/packages/python-xyz.scm (python-numpy)[arguments]: Adjust custom
'fix-executable-paths phase to substitute occurrences of '/bin/true'.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd81cee0f9..7f6bbd55be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5562,7 +5562,10 @@ include_dirs = ~:*~a/include~%" #$(this-package-input "openblas"))))))
               ;; instead of /bin/sh.
               (substitute* "numpy/distutils/exec_command.py"
                 (("'/bin/sh'")
-                 (format #f "~s" (search-input-file inputs "bin/bash"))))))
+                 (format #f "~s" (search-input-file inputs "bin/bash"))))
+              ;; Don't try to call '/bin/true' specifically.
+              (substitute* "numpy/core/tests/test_cpu_features.py"
+                (("/bin/true") (search-input-file inputs "bin/true")))))
           (replace 'check
             (lambda* (#:key tests? outputs inputs #:allow-other-keys)
               (when tests?