summary refs log tree commit diff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-06-25 11:01:39 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-25 11:01:39 +0200
commit583537f2d6b8e5cd7f4b2f6cc7a6d7d2c9aeae7a (patch)
treec1463d6c23463708394ba05bd7b554a98fd00626
parent2f8929482acf709d36e89ba8aca9d281b8cf6831 (diff)
downloadguix-583537f2d6b8e5cd7f4b2f6cc7a6d7d2c9aeae7a.tar.gz
gnu: Add java-commons-text.
* gnu/packages/java.scm (java-commons-text): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/java.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7b0507d93c..16bd0d155a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7908,6 +7908,40 @@ Commons CLI supports different types of options:
 This is a part of the Apache Commons Project.")
     (license license:asl2.0)))
 
+(define-public java-commons-text
+  (package
+    (name "java-commons-text")
+    (version "1.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://apache/commons/text/source/"
+                                  "commons-text-" version "-src.tar.gz"))
+              (sha256
+               (base32
+                "1k99ib2dxlqxb5y94kpzf4ix8xgxz1j3n9kq3ddssqqcccsp5ik2"))))
+    (build-system ant-build-system)
+    (arguments
+     (list #:jar-name "java-commons-text.jar"
+           #:source-dir "src/main/java"
+           #:test-dir "src/test"
+           #:tests? #f                  ; Tests require JUnit5.
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'install
+                 (install-from-pom "pom.xml")))))
+    (inputs
+     (list java-commons-io))
+    (propagated-inputs
+     (list java-commons-lang3
+           apache-commons-parent-pom-51))
+    (home-page "https://commons.apache.org/text/")
+    (synopsis "Library focused on algorithms working on strings")
+    (description "Apache Commons Text is a library focused on algorithms
+working on strings.
+
+This is a part of the Apache Commons Project.")
+    (license license:asl2.0)))
+
 (define-public java-commons-codec
   (package
     (name "java-commons-codec")