summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 00:19:04 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:32 +0000
commit5890d3b70f94fa84001c39c989fb48b00cd9b4a6 (patch)
tree592fb3470ea150fdbaeeccd228d767ac248b8db2
parent18f44da03b9505ab7d232111222cf01fc561ca22 (diff)
downloadguix-5890d3b70f94fa84001c39c989fb48b00cd9b4a6.tar.gz
gnu: Add go-github-com-alecthomas-chroma-v2.
* gnu/packages/golang-xyz.scm (go-github-com-alecthomas-chroma-v2): New variable.

Change-Id: I883a1ca1a84fd35cf0d7fe946fd1caedafae3842
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5b42f10b3f..32b9be40b6 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -110,6 +110,29 @@ substitution.")
 syntax highlighted HTML, ANSI-coloured text, etc.")
     (license license:expat)))
 
+(define-public go-github-com-alecthomas-chroma-v2
+  (package
+    (inherit go-github-com-alecthomas-chroma)
+    (name "go-github-com-alecthomas-chroma-v2")
+    (version "2.12.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/alecthomas/chroma")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1j9zz77ppi4r4ncnanzj84h7bsg0qdqrhgd5kkjiv09afm31jx83"))))
+    (arguments
+     (list #:go go-1.19
+           #:import-path "github.com/alecthomas/chroma/v2"))
+    (propagated-inputs
+     (list go-github-com-dlclark-regexp2))
+    (native-inputs
+     (list go-github-com-alecthomas-assert-v2
+           go-github-com-alecthomas-repr))))
+
 (define-public go-github-com-alecthomas-participle-v2
   (package
     (name "go-github-com-alecthomas-participle-v2")