summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:39:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:39 +0200
commit58a7ed0af31944f7a5758b2b7bad86c4f4695bfa (patch)
tree0fdc2348c49c134e28967fb765eda8c5a6231f14
parentd8cb19a814913653007b2df0869ea071b644eaaa (diff)
downloadguix-58a7ed0af31944f7a5758b2b7bad86c4f4695bfa.tar.gz
gnu: Add texlive-piano.
* gnu/packages/tex.scm (texlive-piano): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d41b65f08d..ee917a906d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11045,6 +11045,25 @@ mode.  All major SI units are included, as well as some @acronym{CGS,
 Centimetre–Gram–Second} units used in astronomy.")
     (license license:lppl1.3c)))
 
+(define-public texlive-piano
+  (package
+    (name "texlive-piano")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/piano/" "tex/latex/piano/")
+             (base32
+              "0nbax18dgg2a9l6bihqhwx0va7829324lk29ibq29wjissmhjqww")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/piano")
+    (synopsis "Typeset a basic 2-octave piano diagram")
+    (description
+     "This package adds the @code{\\keyboard[1][2]..[7]} command to your
+project.  When used, it draws a small 2 octaves piano keyboard on your
+document, with up to 7 keys highlighted.")
+    (license license:lppl)))
+
 (define-public texlive-pinoutikz
   (package
     (name "texlive-pinoutikz")