summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-11 16:51:46 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:47 +0200
commit58ccd118573d56275ac4ca5b8239c9ace7e25a3a (patch)
treec6779947a21c5ce67689a859e80fead58f0ed666
parent74a46fbcb26ec50330de3bb7b63fe211f6c562b7 (diff)
downloadguix-58ccd118573d56275ac4ca5b8239c9ace7e25a3a.tar.gz
gnu: mig-boot0: Do not override phases.
The build phases of the mig package are needed also for mig-boot0, so instead
of overriding all arguments we should only override the configure flags.

* gnu/packages/commencement.scm (mig-boot0)[arguments]: Use
SUBSTITUTE-KEYWORD-ARGUMENTS to replace only the configure flags.

Change-Id: I8227baf9e7fabc86a8674fe694058245ce166d0f
-rw-r--r--gnu/packages/commencement.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index fa07f86451..3d5f79e999 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -13,7 +13,7 @@
 ;;; Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
-;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022, 2024 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2022, 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -2657,11 +2657,11 @@ memoized as a function of '%current-system'."
                           gnumach-headers-boot0))
      (inputs (list flex-boot0 gnumach-headers-boot0))
      (arguments
-      (list
-       #:configure-flags
-       #~(list (string-append "LDFLAGS=-Wl,-rpath="
-                              #$(this-package-native-input "flex")
-                              "/lib/")))))))
+      (substitute-keyword-arguments (package-arguments mig)
+        ((#:configure-flags flags '())
+         #~(list (string-append "LDFLAGS=-Wl,-rpath="
+                                #$(this-package-native-input "flex")
+                                "/lib/"))))))))
 
 (define hurd-headers-boot0
   (with-boot0